在Android Studio中渲染时不支持major.minor版本52.0

jfugit 发布于 2019-08-17 android 最后更新 2019-08-17 16:47 50 浏览

当我尝试在Android Studio中呈现布局预览时,出现错误: 不受支持的major.minor版本52.0

已邀请:

id_cum

赞同来自:

对我来说,将Android Studio更新到最新版本解决了这个问题。

pullam

赞同来自:

对于我的情况,我原来的Android SDK Build-tools版本是24,而Andoid SDK Tools版本是25.1.7。我安装了Andoird SDK管理器的Android SDK Build-tools version 23.0.3。 将这两行修改为: buildToolsVersion "23.0.3" compileSdkVersion 24 然后它的作品!

iut

赞同来自:

如果您看到此错误并且刚刚升级到Android Studio 2.2+,则需要在“项目结构”选项中更新JDK。 在OSX上,可以在File > Project Structure > SDK下找到它。或者从Configure > Project Defaults > Project Structure的欢迎屏幕。 选择Use the embedded JDK (recommended)选项,而不是使用您自己的JDK。 Google的文档尚未更新以反映此更改。请参阅:http://tools.android.com/tech-docs/configuration/osx-jdk

ddolor

赞同来自:

当运行./gradlew makeJar以通过Android Studio 2.2.3创建jar库时,我也得到了“Unsupported major.minor version 52.0”的相同错误消息。 将build.gradle中的gradle插件版本从2.2.2向下移动到2.1.3之后,错误消息消失了,一切运行良好。     classpath'com.android.tools.build:grad:2.1.3' 我不知道高版本的gradle插件是如何导致错误的,但这对我来说很有用。如果你知道答案,请告诉我这是如何工作的,谢谢

tmodi

赞同来自:

不支持的major.minor版本52.0
When a higher JDK is used for compilation it creates class file with higher version and when a lower JDK is used to run the program it found that higher version of class file not supported at JVM level and results in java.lang.UnsupportedClassVersionError.

如何修复
  • 增加用于运行程序的JAVA版本
你可以遵循一些技巧
  • 调用稳定版本类路径'com.android.tools.build:grad:2.1.0'// 2.3.0

配置Gradle 要为项目启用Java 8语言功能和Jack,请在模块级build.gradle文件中输入以下内容:
android {
  ...
  defaultConfig {
    ...
    jackOptions {
      enabled true
    }
  }
  compileOptions {
    sourceCompatibility JavaVersion.VERSION_1_8
    targetCompatibility JavaVersion.VERSION_1_8
  }
}
礼貌转到Java 8 Language Features 只需从预览部分选择“API 23:Android 6.0”即可。 enter image description here

gipsam

赞同来自:

更改为Java SDK到Java 8对我有用。 Android Studio设置:文件 - >其他设置 - >默认项目结构 - > JDK位置 - > jdk1.8.0_71.jdk / Contents / Home

hculpa

赞同来自:

1,确保Gradle Gradle JVM版本 enter image description here 2,确保ProjectSettings SDKs Veriosn enter image description here

modit

赞同来自:

我试图找到解决这个问题的方法。我尝试了这个线程中提到的大多数解决方案。但是,我不太清楚为什么会这样。可能是Android Studio中的一个错误。无论如何,这就解决了这个问题: 在应用程序级build.gradle中, 删除:

  classpath 'com.android.tools.build:gradle:2.2.0-beta1'
替换为:
classpath 'com.android.tools.build:gradle:2.0.0'

hhic

赞同来自:

对于那些仍然面临这种情况的人。 升级到Android Studio到2.1.2后,我遇到了这个问题。 我被困在这个问题大约一个小时,我尝试了这些解决方案:

  1. multidexEnabled true
  2. 增加deamon线程的内存
  3. 升级到Java 8
我仔细检查了gradle脚本,发现了这个:
 compileSdkVersion 23
 buildToolsVersion "24.0.0"
变成:
compileSdkVersion 23
buildToolsVersion "23.0.3"
我不知道这是怎么造成这个错误的,但这对我来说很有用。 如果您知道答案,请告诉我这是如何工作的。 谢谢

vfugit

赞同来自:

改为
应用程序gradle文件中的buildToolsVersion“23.0.2”。

xsit

赞同来自:

对我来说问题是build.gradle中的gradle版本与我安装的实际gradle版本不同。 dependencies { classpath('com.android.tools.build:grade:2.2.0') { force = true} 检查已安装的gradle版本位于/ Contents / gradle / m2repository / com / android / tools / build / gradle / 并使用更改上面的build.gradle文件 classpath('com.android.tools.build:grade:1.5.1')或<>

ased

赞同来自:

我有同样的错误,我把JDK 8设置为JAVA_HOME。原来我安装了Android SDK Build-tools rev 25.0.2。我删除了这个并安装了23.0.2,它对我有用。

bsint

赞同来自:

检查您的JAVA_HOME以使用jdk 1.8 还要检查:Android Studio中的参数以便更改为

File->Other Settings->Default Project Structure->SDKs

xet

赞同来自:

这是因为您在android studio中使用的java版本不兼容,以及与导入项目一起使用的java版本。 去 文件 - >项目结构 - >将jdk 1.7更改为jdk 1.8。然后转到文件 - >单击无效缓存并重新启动。 希望这有帮助.. 并在gradle文件中更改依赖关系类路径 依赖{         classpath'com.android.tools.build:gradle:2.2.3'

    // NOTE: Do not place your application dependencies here; they belong
    // in the individual module build.gradle files
}

siure

赞同来自:

将Java SDK更改为Java 8并为我工作 Android Studio设置: 文件>其他设置>默认项目结构> JDK位置> jdk1.8.0_71.jdk / Contents / Home enter image description here

qenim

赞同来自:

这是Android Studio中的错误。 通常你会收到错误:不支持的major.minor版本52.0 解决方法:如果您已经安装了Android N,请使用旧版本更改Android渲染版本,问题将消失。 解决方案:安装Android SDK Tools 25.1.3(工具)或更高版本 enter image description here

nqui

赞同来自:

我必须在Jenkins-> Manage Jenkins-> Global Tool Configuration-> JDK上将Java版本更新为JDK 8。

nautem

赞同来自:

此错误“不支持的major.minor版本52.0”是指java编译器,尽管字符串“major.minor”看起来与Android SDK版本格式非常相似。 在Windows平台上,除了将jdk更新为1.8之外,请确保JAVA_HOME指向安装jdk 1.8的位置(即C:\ Program Files \ Java \ jdk1.8.0_91)。

tut

赞同来自:

Android Studio在这种情况下表现得很奇怪。即使您在文件 - >项目结构 - > SDK位置中设置了JDK版本,Android Studio也只使用它来编译文件。当它运行这些文件时,由于某种原因,它会查看PATH变量以查找安装java的位置。 如果您的系统上安装了旧版本的Java,那么您的PATH变量将指向旧版本的Java。 因此,您必须将PATH设置为指向Android Studio项目设置中设置的相同版本的Java。 在~/ .bashrc或相应的配置文件中添加以下内容:

export PATH="/Applications/studio.app/Contents/jre/jdk/Contents/Home/bin:$PATH"
在我的情况下,我的项目配置为使用java 1.8,但我的系统范围的java安装是java 1.7。这导致了这个问题。

fearum

赞同来自:

确保在更改Java版本后执行干净构建。事实证明,当您切换JDK时,Android Studio可以正常工作但不会清理工作区并造成混淆¯_(ツ)_/¯

est_et

赞同来自:

下载最新的JDK并安装。转到VS2015工具>选项> Xamarin并将java更改为最新的JDK位置

tvelit

赞同来自:

使用最新版本,建议您切换到嵌入式JDK,如下图所示,这将解决您的错误 resolve major.minor version 52.0 error

out

赞同来自:

此外,如果在执行./gradlew命令时出现问题,请在gradle.properties文件中设置java home,解决此问题: org.gradle.java.home=/usr/java/jdk1.8.0_45/

hculpa

赞同来自:

在我的情况下,我不得不将build.gradle文件的依赖项更改为:

dependencies { 
    classpath 'com.android.tools.build:gradle:2.1.0'
}
(最初是2.2.2) 我想这是通过让几个人在同一个项目中使用不同版本的gradle来生成的。因此,请检查您的gradle版本并正确编辑此文件。 良好的共鸣!

aet

赞同来自:

我已经完成了,设置JAVA_HOME,JAVA8_HOME,......我总是错误。 对我来说,解决方案是将版本2.1.0的gradle设置为与Jdk 1.8.0_92和android studio 2.11一起使用

dependencies {
    classpath 'com.android.tools.build:gradle:2.1.0'
    //classpath 'com.android.tools.build:gradle:2.+'
}