我的应用程序中不支持major.minor版本52.0

xet 发布于 2019-08-17 android 最后更新 2019-08-17 22:31 93 浏览

我试图编译我的Android项目,我得到这个错误

[INFO] Exception in thread "main" java.lang.UnsupportedClassVersionError: com/android/dx/command/Main : Unsupported major.minor version 52.0
[INFO]  at java.lang.ClassLoader.defineClass1(Native Method)
[INFO]  at java.lang.ClassLoader.defineClass(ClassLoader.java:800)
[INFO]  at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
[INFO]  at java.net.URLClassLoader.defineClass(URLClassLoader.java:449)
[INFO]  at java.net.URLClassLoader.access$100(URLClassLoader.java:71)
[INFO]  at java.net.URLClassLoader$1.run(URLClassLoader.java:361)
[INFO]  at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
[INFO]  at java.security.AccessController.doPrivileged(Native Method)
[INFO]  at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
[INFO]  at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
[INFO]  at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
[INFO]  at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
[INFO]  at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
我一直在阅读另一篇文章,试图用Java 8进行编译可能会导致该错误,但不是我的情况,我有以下Java版本:
java version "1.7.0_79"
OpenJDK Runtime Environment (IcedTea 2.5.5) (7u79-2.5.5-0ubuntu0.14.04.2)
OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)
操作系统:Linux Mint (我没有安装Java 8。) 构建:MAVEN 谁能帮我这个?
已邀请:

jquia

赞同来自:

在我的情况下,默认的jdk是1.7然后我通过浏览到找到更新的jdk的确切文件夹将其更改为1.8。

rsequi

赞同来自:

com.android.tools.build:gradle:2.2.0-beta1更改为com.android.tools.build:gradle:2.1.2为我修复了它。 我的Android Studio版本是2.1.2,也许这就是原因

eos_et

赞同来自:

检查您是否在C:\Program Files\JavaC:\Program Files (x86)\Java中安装了最新版本的SDK 然后转到VS2015并按照路径工具 - 选项 - Xamarin - Android设置,在JDK位置选择更改部分,然后去查找x64或x32版本。

uanimi

赞同来自:

这里没有人说的是,使用Build Tools 24.0.0,Java 8是必需的,大多数人都有1.6或1.7。 所以是的,将构建工具设置为23.x.x将“解决”问题,但根本原因是系统上的Java版本。 从长远来看,您可能希望升级您的开发环境以使用JDK8来使用新的语言增强功能和插孔编译器。

qquas

赞同来自:

从android studio制作新项目时我也遇到了这个问题。 我已经能够通过在app gradle设置中降级buildToolsVersion来解决这个问题: 更改{module-name} /build.gradle行

buildToolsVersion "24.0.0 rc1"
buildToolsVersion "23.0.3"

@Edit:
在Android Studio 2.1中转到文件 - >项目结构 - >应用程序 - >构建工具版本。将其更改为23.0.3 做上面的方法,只有当你使用java版本7并且由于某种原因不想升级到java 8时。 希望这可以帮助

vfugit

赞同来自:

我的IntelliJ Maven构建遇到了同样的问题。我的“解决方案”是进入构建工具并删除构建工具24.0.0文件夹。我在{android-sdk-location}/build-tools/目录中找到了它。这不是一个长期的修复,但这至少应该让你的项目再次建立。正如许多人所建议的那样,升级到Java 8将会更好。

asaepe

赞同来自:

我在Cordova,这就是我所做的:

  • 重命名你的android项目,以便有新的空间
  • 将JAVA开发工具包更新为1.8(最新编写本文时) -
  • 运行cordova platform add android 现在应该没有问题。你的应用程序哈希会改变,所以如果你正在使用它f.e.对于facbeook登录,您需要更新它

det

赞同来自:

很抱歉迟到的回复。希望它可以帮助别人 此问题与您的SDK有关,而与您的JDK无关。 您可以从中检查您的版本信息

Help > About > Show Details
你会得到类似的东西
Xamarin.Android Version: 6.0.2.1 (Starter Edition) Android SDK: X:\Android\android-sdk Supported Android versions: 4.0.3 (API level 15) 4.4 (API level 19) 6.0 (API level 23) SDK Tools Version: 24.4.1 SDK Platform Tools Version: 23.0.1 SDK Build Tools Version: 24 rc2 Java SDK: X:\Program Files (x86)\Java\jdk1.7.0_71 java version "1.7.0_71" Java(TM) SE Runtime Environment (build 1.7.0_71-b14) Java HotSpot(TM) Client VM (build 24.71-b01, mixed mode, sharing)
如果您使用预览工具进行构建,那么您将会遇到类似的错误。 现在做什么? 去
Tools -> SDK manager
  1. 选择预览渠道中的所有项目,包括Android SDK build tools和rev 24rc224rc4(最新)
  2. 点击Delete 'n' packages
如何关闭预览频道
  1. 在SDK管理器中,选择
    Tools > options
  2. 取消选中Enable preview tools
什么 回到你的代码清理所有并重建 (在极少数情况下,您必须从项目设置页面中选择构建工具)

ueos

赞同来自:

指定的问题:

Exception in thread "main" java.lang.UnsupportedClassVersionError: com/android/dx/command/Main : Unsupported major.minor version 52.
是在build.gradlebuildToolsVersion 24中声明的,并且我们没有安装此版本所需的Java 8。要解决此问题,我们必须将buildToolsVersion从24更改为最大23: enter image description here Android Studio将来必须要求Java 8,因此我们必须开始使用Java 8。

xeos

赞同来自:

在尝试使用sdk命令行(cordova build android)为Cordova构建时,在Android Studio之外遇到了同样的问题。 Rudy提供的解决方案也适用于这种情况。你只是不要从Android Studio降级Build Tools的版本,但你使用android sdk manager ui。

est_ut

赞同来自:

此问题源于您的构建工具版本和JDK无法一起工作的事实。我使用JDK版本7和构建工具24.0.1。当然,降低构建工具版本可能会解决问题,但这不是一个真正的修复,因为将来升级构建工具会再次破坏它。 您应该确保构建工具版本和JDK一起工作。我将构建工具升级到最新版本(24.0.1)并安装了jdk8。确保将JAVA_HOME设置为最新版本,然后尝试清理构建。

qnon

赞同来自:

在eclipse中创建一个新项目时我也遇到了这个问题。

  1. 打开您的eclipse安装目录
  2. 打开文件eclipse.ini
  3. 修改
    Dosgi.requiredJavaVersion=1.6 
    
    Dosgi.requiredJavaVersion=1.7
    
希望这可以帮助

jquia

赞同来自:

我在Android Studio 2.0上遇到了同样的问题。 Rudy Kurniawan提供的解决方案解决了这个问题。受影响的文件可通过以下方式找到: “Project” - >“Android” - >“Gradle Scripts” - >“build.gradle(Module:app)” “项目”窗格默认位于左侧。要查找它,请检查侧面标签的名称,单击它,然后使用顶部下拉框进入“Android”。展开窗格中的树以查找目标文件。双击它进行编辑。

baut

赞同来自:

在travis构建服务器上获取此错误消息? 我修复了我的travis构建 buildToolsVersion“24.0.2”使用此

# travis build 
language: android
jdk:
  - oraclejdk8
android:
  components:
    - tools
    - build-tools-24.0.2
    - android-23
- add-on
    - extra
script:
  - jdk_switcher use oraclejdk8
  - ./gradlew assemble

hid

赞同来自:

最初我将24.0.0 rc3从PLACEHOLDER_FOR_CODE_1降级为23.0.3,如Rudy Kurniawan的回答所述。然后我注意到我的项目设置中指定了jdk 7。我已将其更改为jdk 8,现在构建工具24.0.0 rc3工作。 enter image description here 将编译选项设置为java7也很重要:

android {
    ...
    compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_7
        targetCompatibility JavaVersion.VERSION_1_7
    }
}

ysequi

赞同来自:

我遇到了同样的问题,并尝试更改版本,有时是在Project> Gradle Scripts> build.gradle(模块:app)中的Android Studio版本,您可以更改版本。例如:

android {
    compileSdkVersion **23**
    buildToolsVersion **"23.0.3"**
defaultConfig {
        applicationId "com.example.android.myapplication"
        minSdkVersion **19**
        targetSdkVersion **23**
        versionCode **1**
        versionName **"1.0"**
    }

xporro

赞同来自:

我安装了两个版本的java jdk。一旦我将文件 - >项目结构 - > SDK位置中的正确版本的java jdk指向我在JAVA_HOME环境变量中的最新版本,问题就消失了。

amodi

赞同来自:

您的Android构建工具未正确安装。尝试安装其他版本的构建工具,并将该版本提供给gradle文件。 或者你可以去这个目录 C:\用户\应用程序数据\本地\ Android的\ SDK \构建工具 并查看已安装的构建工具。尝试更改gradle文件中的构建工具版本并编译应用程序以查看它是否正常工作。 我有22.0.1,23.0.02和24.0.0版本的构建工具,只有旧的22.0.1版本工作。 来源:我自己尝试过,它对我有用。

yeum

赞同来自:

我有这个问题太久了(SO等没有帮助),只是解决了它(使用sdk 25)。

  • local.properties文件proguard.dir var没有应用于ant;我已经指定了5.3.2,但命令行调用和签名导出构建(eclipse)使用的是4.7,来自sdk目录(只有5+支持java 8) 我的解决方案是使用当前(5+)版本的proguard替换sdk中的proguard jar(android-sdk / tools / proguard / libs目录)。

sit_in

赞同来自:

52是JDK 8的代码。您可以在这里看到:http://javarevisited.blogspot.com/2015/05/fixing-unsupported-majorminor-version.html。因此,Gradle希望您将JDK 8作为计算机上的默认Java版本。最新版本的Gradle for Android不适用于Java 7。 解决方案很简单:将Java 8作为您计算机上的默认jdk版本。

liste

赞同来自:

Gradle Scripts >> build.gradle(模块应用) 将buildToolsVersion“24.0.0”更改为buildToolsVersion“23.0.3” 来源:经验

ut_et

赞同来自:

找到所有用户的解决方案都存在这个问题。

  • 错误com / android / dx / command / Dexer / main不支持的版本52.0 major.minor eclipse
  • 不支持的版本52.0 major.minor ECLIPSE
ECLIPSE问题的解决方案在您的project.properties文件中写入:
sdk.buildtools = 23.0.3
解决问题的解决方案是ANDROID是STUDIO版本2.1 FILE在BUESTRO project.properties中写这个:
sdk.buildtools = 23.0.3

oalias

赞同来自:

谢谢大家的解决方案。 我可以使用以下解决方案解决我的同样问题。 在我的项目中,我添加了在Java8中创建的jar。我的项目是指JRE 7.当我将项目JRE更改为8.我的问题解决了。 步骤:在eclipse中,右键单击项目资源管理器中的项目名称>构建路径>库>单击jre版本>单击编辑>已安装JRE>添加> standerd VM>选择JRE主页单击路径(路径应为localePath \ java \ jdk1 .8.0_25 \ jre)>提供名称>保存>为项目选择相同的JRE>完成>确定刷新/构建项目一次>尝试运行您的java文件。它应该工作。

tmodi

赞同来自:

我安装了Android Studio和Xamarin Visual Studio(已安装)。在安装之后(排除SDK,因为它们已经安装)我启动了Android Studio,它下载,安装并添加了缺少的SDK(在给出SDK位置的路径之后)。结果我在构建时收到了错误消息

java.lang.UnsupportedClassVersionError: com/android/dx/command/Main : Unsupported major.minor version 52.0
作为解决方案,我在没有JRE的情况下安装了jdk-8u101-windows-i586.exe(因为它已经安装)。在我尝试x64版本之前,它已经消失了......那么你必须更改Java Development Kit locationChange JDK location 这可以通过单击工具>选项> Xamarin> Android设置在Visual Studio中完成。在这里,您可以导航到正确的位置。就我而言,它是C:\Program Files (x86)\Java\jdk1.8.0_101。 最后,清理你的项目并进行新的构建:-)

equia

赞同来自:

不支持的主要次要版本错误可能是因为不支持的JDK版本。更新JDK,转到“模块设置”并将JDK路径更改为新路径。在大多数情况下,它修复了错误。

eomnis

赞同来自:

最简单的解决方案是您必须将JDK更新为最新版本。因为Cordova仅支持最新的JDK。 1.首先,您必须更新Android SDK。然后, 2.如果您无法通过终端更新,请访问您的Linux软件中心并搜索最新版本(您要安装哪一个)并安装该版本。 然后再次运行Cordova构建。 它将解决问题。 在,我的情况下它工作。

snon

赞同来自:

我刚遇到这个问题。 从SDK工具和构建工具的“预览频道”版本恢复到最新的稳定版本修复它。

et_et

赞同来自:

来自this问题。 您可以尝试在您使用的IDE中将编译器级别更改回1.7。

  • 如果您使用的是Eclipse,请转到Windows ---> Prefences,然后选择Java并展开它,然后选择Compiler并将合规性级别更改为1.7。
  • 如果您使用的是Android Studio,则可以将其添加到build.gradle中
    android {
        compileSdkVersion 19
        buildToolsVersion "19.0.0"
    defaultConfig {
            minSdkVersion 7
            targetSdkVersion 19
        }
    compileOptions {
            sourceCompatibility JavaVersion.VERSION_1_7
            targetCompatibility JavaVersion.VERSION_1_7
        }
    }
    
如果这没有帮助,请尝试查看上述链接中的其他答案,并告诉我们是什么帮助您。

qodio

赞同来自:

您需要进入SDK安装目录,并确保/ build-tools子目录与应用程序的build.gradle文件中的buildToolsVersion匹配: enter image description here