是否应该现在跟进升级到 5.4 内核的意见收集

isunt 发布于 2020-06-17 lede 最后更新 2020-07-09 11:49 108 浏览

关于是否应该现在跟进升级到 5.4 内核的意见收集

升级到 5.4 内核将获得:

  1. 更及时的内核补丁支持
  2. 新硬件的驱动,例如 AMD Zen2 APU 的 GPU 解码,2.5Gbps 各种网卡的支持, 新的 ARM 处理器例如 IPQ8xxx 和 IPQ6xxx 支持等
  3. 新的 DSA 网卡模型,例如 MT7503 可以强制指定每一个端口的速率解决掉线问题
    .... 等等

升级到 5.4 内核将失去的:

  1. 效能。 5.4 内核的 Flow 比 4.19 慢了 10-18% 以上,低端硬件特别明显。
  2. 闭源驱动,例如 K2P 的驱动并没有在 5.4 内核中被支持
  3. 更多的 Bug ,因为 5.4 不是正式 LTS 内核,也没有 stable release 的 OpenWrt 源码
  4. 5.4 内核的 DSA 驱动不支持 VLAN 交换机配置
  5. MAC80211 的 5.4 无线驱动目前测试过没有一个版本是好用的,要不就速率极低

附上 AC2100 无线性能测试性能图表, 分别为目前我的 OP 分支,集客, 官方 5.4 Snapshot 无线

image

PS: 5.4 内核寿命延长了,变为 LTS 了

大家意见如何?

已邀请:

miure

赞同来自:

不要,k2p再用5年

zsed

赞同来自:

没有新硬件,不更新。

xquis

赞同来自:

做个 5.4 的分支?

mest

赞同来自:

反对,稳定好用才是最要紧

lillo

赞同来自:

不追新,路由硬件更换速度不高

umodi

赞同来自:

不要。反对!不更

siusto

赞同来自:

不要,稳定才好。

tut

赞同来自:

等LTS的内核出来再升级

seaque

赞同来自:

x64 x86 支持

hquae

赞同来自:

反对,或者做个 5.4 的分支

vdicta

赞同来自:

不建议更新 5.4 内核

nautem

赞同来自:

单独x86更新5.4?

ksit

赞同来自:

不建议跟新 没有这方面的需求 大家的网络是不是也没有达到这个级别了

sed_et

赞同来自:

个人认为,稳定高效才是王道。

but

赞同来自:

当前版本很好,稳定又高效

qullam

赞同来自:

x86的可以试试,硬路由就算了吧

adolor

赞同来自:

armv8的强烈推荐,x86无所谓,看大雕心情??

jneque

赞同来自:

不建议更新,如果确实需要的话建议拉个分支。

killo

赞同来自:

x64 x86 支持

uharum

赞同来自:

等下一个longterm版本再升级

ut_sit

赞同来自:

等下个lts内核

lquia

赞同来自:

建议稳定后再更吧,可以放到一个新分支里,或单独一个库里,如果有尝鲜的可以在那里。

路由器在稳定的同时,再提供很棒的功能挺重要的,如果各种蛋疼事情,反而不好。

内核除非变成LTS支持,不然并不建议,不是大家的硬件都能这么快与时俱进的。

met

赞同来自:

5.4也是长期支持版本了,支持期是6年,也就是到2025年截至,可以开个5.4的分支,至于FLOW性能损失这个,因为Flow Offloading引起不少问题,所以我都是直接关闭的,也没看到对实际占用率有什么大影响,所以我认为暂时不需要考虑这个性能

bquos

赞同来自:

不建议升级也不建议新分支,权衡利弊。真有拿最新硬件去玩openwrt的吗,估计非常少非常少。稳定压倒一切,升级非lts内核,升级出更多的bug。做精一个分支我就觉得很赞。

nea

赞同来自:

与其维护一个不确定的内核,还不如花精力搞好现有的

xid

赞同来自:

nonono

yet

赞同来自:

应该上,不折腾和咸鱼有什么区别

matque

赞同来自:

支持升级X86用最新的内核。

iaut

赞同来自:

支持X86上5.4
PS:感觉issues里征求这个意见基本就决定了否定的居多

nin

赞同来自:

支持升级,关于那个效能平时都是提升50% 80% 100%什么的
现在才降低10-18%,丝毫不影响,下次再提升个50%即可

baut

赞同来自:

不支持,作为一个路由器系统,我认为稳定才是第一要务,其他绝大多数问题都需要给稳定性让路。
况且支持时间这么短,上的话还会花很多时间折腾,感觉有点得不偿失?

jautem

赞同来自:

反对,稳定好用才是最要紧!

hculpa

赞同来自:

可以开test 分支。这样比较好,至于FLOW性能损失这个,因为Flow Offloading引起不少问题,所以我都是直接关闭的,也没看到对实际占用率有什么大影响,所以我认为暂时不需要考虑这个性能

就是!我从不编译Flow Offloading!

det

赞同来自:

虽然我用x86,性能啥的无所谓,不过建议还是等等再说,万一有内核bug很麻烦,牵一发而动全身。目前的4.19版本已经比较稳定了,想要折腾的自己开分支吧。

isit

赞同来自:

路由器稳定最重要
新功能可以放近测试项目里

fet

赞同来自:

建议增加新分支,虽然内核时间较短,性能下降,但总体来说可以试试水,为以后新设备铺路,毕竟现在wifi6价格血拼如此低,可以预想的,未来5G 千兆 wifi6

zfugit

赞同来自:

对于路由器来说,稳定好用才是最重要的,为了追新失去太多不太值得。对于部分设备有必要升级5.4内核的可以考虑单开新分支/单独支持(虽然这样会稍微增大工作量吧,各位辛苦了:)。
(另外,Linux 5.4 LTS不是到2025才会EOL吗? Link: The Linux Kernel Archives

eet

赞同来自:

对于路由器来说,稳定好用才是最重要的. 不建议更新 5.4 内核

dsit

赞同来自:

建议等内核LTS。
不过可以考虑先建立分支,包括mac80211、DSA改动相对较大,升级需要花费时间进行适配,可先行在分支上进行测试。

fet

赞同来自:

不要

kex

赞同来自:

https://www.kernel.org/category/releases.html
Linux内核官网上写的不是支持到2025年12月吗?
建议升级到5.4

enemo

赞同来自:

可以弄个5.4分支

sit_et

赞同来自:

可以弄个5.4分支

+1

gut

赞同来自:

5.4是官方的LTS内核,稳定性应该没问题,放心用吧

et_ea

赞同来自:

支持升级

csequi

赞同来自:

其实理由只有一条,koolshare已经升级5.4了,再不升就被超过了。

eet

赞同来自:

不要,稳定才好。

hquae

赞同来自:

升吧

reum

赞同来自:

不更新。稳定是第一位。要折腾or尝新,可以新开分支。主分支还是要稳住。

trerum

赞同来自:

都玩软路由了,何必在折腾硬路由,直接用原厂固件不就行了吗

punde

赞同来自:

5.4的生命周期延长到2025年,好像也是LTS啊,从https://www.kernel.org/ 看的是lts。虽然官方openwrt的主分支已经更新了5.4内核,但是如果对性能影响较大的话可以暂时不升级

jenim

赞同来自:

X86可以单独搞一个选项到5.4,其它的没有必要~~~

rquis

赞同来自:

没有新硬件,不更新。

icum

赞同来自:

维稳重要,不追新~辛苦了

zamet

赞同来自:

5.4是长期更新版本,升噻。

感谢L大和各位开发人员的努力。

xest

赞同来自:

5.4是长期更新版本,升噻。

感谢L大和各位开发人员的努力。

好像续命了

rquis

赞同来自:

本人亲测 lienaol 5.4.32 master内核三个月使用体验,非上面无脑评论:
1、5.4内核使用非常稳定,无内存泄漏及长期使用网络延迟等不稳定现象,master分支已经非常成熟,为何不更新;
2.、5.4内核比4.19内核的cpu占用率和温度下降20%,4.19内核无主动散热温度50度时,5.4内核在42度左右,新内核效能机制已经体现无疑;
3、linux官方5.4内核已经是长期支持版本,连ubuntu和PVE都已升为此版本或更高版本,为何众人还是痴迷于老版本不做改变,并且我的OMV主机已经官方升为5.6内核并使用非常稳定,openwrt的使用者都是以最新为乐,稳定的同时最求最佳性能也是主要的目标,L大也是新技术的倡导者,个人建议还是有最新内核技术为佳。谢谢L大长期以来给我们带来最新openwrt的体验。谢谢

ased

赞同来自:

补充:本人四台路由主机,E2 1275L v3 、E3 1230L v3、J3160、J1900 这四台用在我的四套房子里,不做pve虚拟,单独主机使用。之所以四台主机一直使用lienol固件就是因为L大的固件是4,19,原因就如上面所述。如果大家对lienol master分支固件最后一版有优化就知道其固件的优势,虽然目前早已停止更新。

cut

赞同来自:

可以更新啊,毕竟将来都是要支持新硬件的。想稳定的,停留在目前版本就好。

wab

赞同来自:

本人亲测 lienaol 5.4.32 master内核三个月使用体验,非上面无脑评论:
1、5.4内核使用非常稳定,无内存泄漏及长期使用网络延迟等不稳定现象,master分支已经非常成熟,为何不更新;
2.、5.4内核比4.19内核的cpu占用率和温度下降20%,4.19内核无主动散热温度50度时,5.4内核在42度左右,新内核效能机制已经体现无疑;
3、linux官方5.4内核已经是长期支持版本,连ubuntu和PVE都已升为此版本或更高版本,为何众人还是痴迷于老版本不做改变,并且我的OMV主机已经官方升为5.6内核并使用非常稳定,openwrt的使用者都是以最新为乐,稳定的同时最求最佳性能也是主要的目标,L大也是新技术的倡导者,个人建议还是有最新内核技术为佳。谢谢L大长期以来给我们带来最新openwrt的体验。谢谢

同感,希望L大不要被楼上的人忽悠了,最好就软路由单独弄出一个分支,凭什么让我们一部分用户等一群K2P顽固党??????

podio

赞同来自:

K2P总归不支持802.11ax新标准,信号再好速率也无法再快,迟早也会被淘汰的,何必恋旧。

bsequi

赞同来自:

k2p的5.0.4.0驱动可以支持新内核,新内核改过的部分api在新驱动通过条件编译已经支持了,国外论坛貌似也有人在5.x内核跑起来了。

uin

赞同来自:

大雕更新了主帖,表明这个不是LTS版本哎,这可能就不是长久之计了。

kalias

赞同来自:

全部的LEDE玩家要为一部分的k2旧硬件玩家让步,让我看呆了。既然5.4是LTS为何不升?玩LEDE不就是追求更新的系统吗?我还玩BCM的光猫呢,是不是还得为我回退到3.X内核?

hid

赞同来自:

没有特别需求可以升级,建议开个新的分支。

yalias

赞同来自:

全部的LEDE玩家要为一部分的k2旧硬件玩家让步,让我看呆了。既然5.4是LTS为何不升?玩LEDE不就是追求更新的系统吗?我还玩BCM的光猫呢,是不是还得为我回退到3.X内核?

还有一部分是软路由追求稳定的,然而软路由这东西,玩的不就是折腾?

tin

赞同来自:

大雕定了吧,改不改都不错都可以。中国人讲民主不是穷开心吗

quia_a

赞同来自:

k2p测了下,5.4内核+闭源驱动+CPU 频率1G,iperf3测得wan to 5g速率 580+M,比4.14强点。

raut

赞同来自:

全部的LEDE玩家要为一部分的k2旧硬件玩家让步,让我看呆了。既然5.4是LTS为何不升?玩LEDE不就是追求更新的系统吗?我还玩BCM的光猫呢,是不是还得为我回退到3.X内核?

还有一部分是软路由追求稳定的,然而软路由这东西,玩的不就是折腾?

追求稳定的就不会天天来拉源码更新去刷机,刷好了就不会动他了。所以那些说为了稳定而放弃新内核的都是伪需求,一边喊着要稳定一边天天重启刷机,言行不一。

zamet

赞同来自:

不建议更新 5.4 内核,稳定高效最重要

yeum

赞同来自:

墙烈要求升级5.4 追新就是玩openwrt精髓之一

nsunt

赞同来自:

x86表示没有更新的必要
下个LTS内核再说吧

fearum

赞同来自:

5.4 整体其实挺稳定的,只是 官方最新板本的UPNP 不大好用 一直没用。

wqui

赞同来自:

如果升5.4不难的话,我认为应该升上去。如果有一定难度(比如各插件需要适配/修bug)我认为不应该升。毕竟5.4和4.19的EOL时间点只差了1年,不管现在换不换,2024/25年就得换新内核了。不如等快到EOL的时候再换最新的LTS版本。

yhic

赞同来自:

我还在奇怪呢,op官方源码早就升级到5.x了,怎么大雕一直没跟进啊。
至少X86先升上去吧,其他架构可以再看看情况,等适配的差不多稳定了再跟进。

equi

赞同来自:

不要升级,反对,我觉得应给等5.4稳定后再升级

pnon

赞同来自:

支持更新,不能老抱着过时的东西不放,老设备毕竟要淘汰的,x86 10G 网卡及 ARMv8-A、Wifi6 已经成为了当代主流,并且 linux 5.4 分支小版本已经迭到了 48,已经非常非常稳定,L 大千万不要被上面某些老掉牙免费设备玩家左右了,如果真要顾及这些老设备,可给 4.19 老内核建个分支。但如果十分顾忌老设备用户的感受而对新设备用户的感受置若罔闻,这将会对项目的发展不利。

baut

赞同来自:

建议新开分支做5.4内核,老内核少维护(修复bug不增加功能)以便使用4.19内核的老设备还能稳定使用。

vfugit

赞同来自:

把当前的切到另一个分支,主分支继续升级到5.4吧

ynulla

赞同来自:

noptio

赞同来自:

上5.4用DOCKER PLEX硬解没什么问题,4.19运行一段就会挂掉。。。我自己这边是这样不知道别人会不会有类似的问题哈

hquae

赞同来自:

个人认为op是在稳定和追新的平衡上偏追新的,如果5.4没有太多BUG的话我支持升到5.4。

tmodi

赞同来自:

支持升级

kautem

赞同来自:

既然L大提出了这个issue了,说明是有意愿升的。旧的东西终归要淘汰,我支持升。来到这里的,都是爱折腾的。

prem

赞同来自:

建议更新,要坚持求新,与时俱进,

qporro

赞同来自:

几天没来5.4居然lts了?!那么不用想,升就一个字!

sit_id

赞同来自:

更喜欢新的,这也是大势所趋。

verror

赞同来自:

生命在于折腾,如果不追求新技术新事物,怎么适应新时代.
旧的设备注定终究是要被淘汰的.
新的kernel是有它存在的理由的.
还有在我看来,那些说要求稳定的人,你用的是AS路由还是Core路由?
一个家用路由,再怎么稳定也无法抗拒断电,断网的意外事件.你家又不是DATA Center.
过几年也许会10G光纤入户时,不知道你们这些人是否还是一样的态度.

eomnis

赞同来自:

我只想 packages 大部分包整体先更新一下。

wmagni

赞同来自:

另外 K2P在5.4内核上的7615闭源驱动 已经有了
Lienol/openwrt@5c1aa1d

id_aut

赞同来自:

关于是否应该现在跟进升级到 5.4 内核的意见收集

升级到 5.4 内核将获得:

  1. 更及时的内核补丁支持
  2. 新硬件的驱动,例如 AMD Zen2 APU 的 GPU 解码,2.5Gbps 各种网卡的支持, 新的 ARM 处理器例如 IPQ8xxx 和 IPQ6xxx 支持等
  3. 新的 DSA 网卡模型,例如 MT7503 可以强制指定每一个端口的速率解决掉线问题
    .... 等等

升级到 5.4 内核将失去的:

  1. 效能。 5.4 内核的 Flow 比 4.19 慢了 10-18% 以上,低端硬件特别明显。
  2. 闭源驱动,例如 K2P 的驱动并没有在 5.4 内核中被支持
  3. 更多的 Bug ,因为 5.4 不是正式 LTS 内核,也没有 stable release 的 OpenWrt 源码
  4. 5.4 内核的 DSA 驱动不支持 VLAN 交换机配置
  5. MAC80211 的 5.4 无线驱动目前测试过没有一个版本是好用的,要不就速率极低

PS: 5.4 内核寿命延长了,变为 LTS 了

大家意见如何?

做个 5.4 的分支

set

赞同来自:

没必要,再等半年再说

miste

赞同来自:

稳定才是最好的

fomnis

赞同来自:

关于是否应该现在跟进升级到 5.4 内核的意见收集

升级到 5.4 内核将获得:

  1. 更及时的内核补丁支持
  2. 新硬件的驱动,例如 AMD Zen2 APU 的 GPU 解码,2.5Gbps 各种网卡的支持, 新的 ARM 处理器例如 IPQ8xxx 和 IPQ6xxx 支持等
  3. 新的 DSA 网卡模型,例如 MT7503 可以强制指定每一个端口的速率解决掉线问题
    .... 等等

升级到 5.4 内核将失去的:

  1. 效能。 5.4 内核的 Flow 比 4.19 慢了 10-18% 以上,低端硬件特别明显。
  2. 闭源驱动,例如 K2P 的驱动并没有在 5.4 内核中被支持
  3. 更多的 Bug ,因为 5.4 不是正式 LTS 内核,也没有 stable release 的 OpenWrt 源码
  4. 5.4 内核的 DSA 驱动不支持 VLAN 交换机配置
  5. MAC80211 的 5.4 无线驱动目前测试过没有一个版本是好用的,要不就速率极低

PS: 5.4 内核寿命延长了,变为 LTS 了

大家意见如何?更新把早晚的事

wnatus

赞同来自:

支持升级

out

赞同来自:

支持升级!!!!

het

赞同来自:

支持升级

veos

赞同来自:

支持升级

lvero

赞同来自:

支持升级

mest

赞同来自:

支持升级!