在win64上的Eclipse

qenim 发布于 2018-03-09 eclipse 最后更新 2018-03-09 01:00 1153 浏览

有人在Windows XP或Vista 64位上成功使用Eclipse的最新64位Ganymede发行版吗? 目前,我在32位JDK上运行普通的Eclipse 3.4发行版,并启动&用64位JDK编译我的应用程序。我们之前的经验是,64位Eclipse发行版对我们来说是不稳定的,所以我很好奇,如果有人正在成功使用它。 我们正在使用JDK 1.6.0_05。

已邀请:

zex

赞同来自:

我已经在Vista x64上成功使用它来完成一些轻量级的Java工作。没有太多的参与,没有额外的插件,但基本的Java编码工作没有任何问题。我正在使用3.4M7版本,但它看起来像3.4 stable build现在支持Vista x64。

yut

赞同来自:

我使用的是64位VM的Eclipse。不过,我必须使用Java 1.5,因为在Java 1.6中,甚至1.6.0_10ea,Eclipse在更改.classpath文件时会崩溃。在Linux上,我遇到了同样的问题,只能让64位Eclipse与64位Java 1.5一起工作。 这个问题似乎与刚刚编译的时间有关,因为使用vmparam -Xint eclipse工作 - 但这不是一种溶剂,因为它很慢。 修改 随着1.6.0_11它似乎工作。 1.6_10 final可能与评论中提到的一样,但我没有测试过。